rukind.com

Grateful Dead Music Forum

A place to talk about the music of the Grateful Dead 

 #111710  by gr8fullfred
 Tue Mar 27, 2012 6:52 am
Just my 2 cents:

I finally saw the Stella Blues Band last Saturday night. I really enjoyed seeing/meeting them. A great band that does a very authentic interpretation of the music we all love. Mike has a beautiful fancy cowboy, and produces awesome Bobby-ness from it, apparently plugged directly into a Roland amp (did not see any pedals). Really killer Bobby sounds from a stunning Cowboy Ibanez, I think he said it was a 2005.

Keep up the good work,Fred
 #116145  by shannonjim2
 Mon Jul 16, 2012 2:55 pm
I am way late to this topic, but I have a 2681, and it is my #1 at the moment. Had it for about 18 months now - and agree that it is heavy, but it is such a good looking guitar- with the tree of life inlay, that I can't do without it. My only issue is that I feel the original pickups are a bit muddy on the low end. Really nothing I have found to fix that up - but a good flanger helps it out in my uneducated opinion - that would be my only complaint. The high end is crystal clear - I am playing it through a Fender Twin Reverb (not on bright setting becaue that is too much), so that probably helps this highs.
 #116282  by zambiland
 Thu Jul 19, 2012 10:48 pm
I've got a 2680 that I added a Hi-A strat pickup in the middle and a home made 2 band eq/buffer. Sounds great. I love the pickups. I find that for an SG style guitar, it really doesn't get muddy at all. However, it doesn't get played hardly at all.
 #135034  by bcresci
 Sat Dec 21, 2013 8:30 am
I have a 2681 reissue (from mid 90s). Will also reitterate that this one gets a bit heavy after a while. But with a little exercise, you can make it through that. I find the neck weight to be a bit more problematic for me - due to the weight, the neck keeps sinking on me and I have to keep lifting it. So overall, the guitar's balance doesn't feel great to me. But man... it is a beautiful instrument.
 #135157  by douglasa
 Sat Dec 28, 2013 9:43 am
I had the same problem with my Ibanez Weir guitar that I bought new in April '77. I installed a strap button on the back, where it would be on an ES-335. Problem solved!