Page 1 of 4

Jerry Pre-amp mods

PostPosted:Tue May 10, 2011 8:47 pm
by schmidtz
My Twin had developed a tic in the trem while it was stored away while I was at college, so I brought it down to Savage Amps (the guys that do Bobby's amps) and decided I want to do full out Jerry mods.

I basically ripped everything off of Waldo's site, but I don't know if the wording is correct.

Basically, is anything on here going to make me look like a fool? (i.e. mods that can only be done to the AB763, while mine is a Ultralinear SF)


START NOTE:
Hopefully this will turn my 1978 Twin into something more like a 68-70.


-General Blackfacing. I have no idea what to do to make that happen, but you guys are the experts :-)


-Removal of the 68k Input Resistors to remove "Hiss" associated with them

-plate resistors swapped for Non Inductive Metal Film Military Spec'd Type RN65 or RN70

-Cathode Bypass Capacitors swapped out for Military Spec'd Axial Solid Tantalum 150D series/CSR13's

-Bass cap .022uf Polyester Film(Sprague 225p) / Mid Cap .022uF Polyester Film(Sprague 225p) / Treble Cap 250pF Silver Mica/ Bright Cap 120pF Silver Mica

-ALL stock Potentiometers swapped out for ALLEN BRADLEY MIL SPEC TYPE J/ RV4 type

-Matched .1uF Output Coupling Capacitors

-Matched RN65 or RN70 220k Bias Splitter Resistors

-Hand Selected Metal Film 100k & 82K Phase Inverter Resistors

-Hand Select the Reverb input 500pf off of the .02 uF coupling capacitor of the V4a grid network. A Silver Mica capacitor should be used to keep the tolerance tight.

-Hand select the reverb mix 3.3 Meg Resistor and 10pF Capacitor paralleled with it. A Silver Mica capacitor should be used for the 10pF to keep the tolerance tight.

-The stock Reverb 100k linear potentiometer swapped for a 100k Log/Audio.

-fix "tic" associated with trem circuit

-remove master volume circuit


Thanks all, and again, LOVE this resource!

Re: Jerry Pre-amp mods

PostPosted:Thu May 12, 2011 3:42 am
by oldsmojo
Hey man...been busy all week with Ultra-linear model twins. I have 2 right here I just finished and they are absolutely the best twins I've ever heard and I've blackfaced and Jerry modded over 50 difft twins from all years! I set them up to really nail the fat/clear '82 tone on one side and the cleaner late 80's tone on the other side. Both having reverb with nice long decay. The stock ultra-linears are total dogs and would actually sound pretty crappy with all these mods in them especially with the tantalum caps and metal film plate resistors. Where do you live and what did Savage say these mods would cost if you dont mind me asking? ~Joe Martin

Re: Jerry Pre-amp mods

PostPosted:Thu May 12, 2011 6:02 pm
by schmidtz
I'm in the Twin Cities.
Savage hasn't quoted me yet.

If you say you have good mods, by all means, do tell!!

I thought tantalum was bad....

Re: Jerry Pre-amp mods

PostPosted:Thu May 19, 2011 12:19 pm
by hippieguy1954
Hey man...do you guys know anyone in NY state that does the twin mods?

Re: Jerry Pre-amp mods

PostPosted:Thu May 19, 2011 12:21 pm
by playingdead
Joe (oldsmojo who just posted above) is in the NYC area ...

Re: Jerry Pre-amp mods

PostPosted:Sun Jun 05, 2011 4:07 pm
by hippieguy1954
schmidtz wrote:I'm in the Twin Cities.
Savage hasn't quoted me yet.

If you say you have good mods, by all means, do tell!!

I thought tantalum was bad....
Hey schmidtz, did Savage give ya a quote yet? I need the same mods to my '79 ultra linear. With 135 watts it should sound great with the mods you listed. I got one quote of $500 so far. Think it's kinda high, but not sure...what ya think?

Re: Jerry Pre-amp mods

PostPosted:Sun Jun 05, 2011 4:32 pm
by RiverRat
schmidtz wrote: -ALL stock Potentiometers swapped out for ALLEN BRADLEY MIL SPEC TYPE J/ RV4 type

Skip the milspec pots and you'll shave about $100 off.

I have a Bill of Materials with part numbers for Newark.com if you're interested.

Re: Jerry Pre-amp mods

PostPosted:Sun Jun 05, 2011 5:23 pm
by hippieguy1954
playingdead wrote:Joe (oldsmojo who just posted above) is in the NYC area ...
Thanks man, I really appreciate your responce. Peace

Re: Jerry Pre-amp mods

PostPosted:Sun Jun 05, 2011 5:36 pm
by hippieguy1954
RiverRat wrote:
schmidtz wrote: -ALL stock Potentiometers swapped out for ALLEN BRADLEY MIL SPEC TYPE J/ RV4 type

Skip the milspec pots and you'll shave about $100 off.

I have a Bill of Materials with part numbers for Newark.com if you're interested.
Sure, RiverRat. I'm interested! I'm also tryin to find out for sure if these mods work for the '79 ultra linear. Like schmidtz said in his first post "Basically, is anything on here going to make me look like a fool? (i.e. mods that can only be done to the AB763, while mine is a Ultra linear SF).

Re: Jerry Pre-amp mods

PostPosted:Sun Jun 05, 2011 9:12 pm
by schmidtz
Unfortunately, Savage hadn't even looked at it after three weeks, so I decided to skip it and try myself.

I settled on just replacing the coupling and power caps. I also lifted the legs on my vibrato to stop the ticking.

This does bring up another point, however. I have the MC250 and I want to preamp the twin. Could I just run a wire from the preamp spot on the tag board and tie it into the positive node on my vibrato RCA?

The other thing I can think of is actually removing the vibrato's white wire, solder in the red preamp wire in, and use the existing negative wire.

Thoughts?

Re: Jerry Pre-amp mods

PostPosted:Mon Jun 06, 2011 3:09 am
by hippieguy1954
Waldo has a good schematic for the preamp tap on his site. It looks very easy.

Re: Jerry Pre-amp mods

PostPosted:Mon Jun 06, 2011 1:49 pm
by hippieguy1954
schmidtz wrote:Unfortunately, Savage hadn't even looked at it after three weeks, so I decided to skip it and try myself.

I settled on just replacing the coupling and power caps. I also lifted the legs on my vibrato to stop the ticking.

This does bring up another point, however. I have the MC250 and I want to preamp the twin. Could I just run a wire from the preamp spot on the tag board and tie it into the positive node on my vibrato RCA?

The other thing I can think of is actually removing the vibrato's white wire, solder in the red preamp wire in, and use the existing negative wire.

Thoughts?
I would shorten the list to whats below and think it would sound great, but I’m still not sure about the values of the components. I’ve been tryin to find out if these values are only for 100 watt twins or are they fine in the ultra linear 135 watt as well. I have seen a few kits for modding the 100 watt twins for similar Jerry sound that specifically say NOT FOR ULTRA LINEAR 135 watt twins. That’s why I’m not gonna spend all the money for the parts yet and do it myself.
-plate resistors swapped for Non Inductive Metal Film Military Spec'd Type RN65 or RN70

-Cathode Bypass Capacitors swapped out for Military Spec'd Axial Solid Tantalum 150D series/CSR13's

-Bass cap .022uf Polyester Film(Sprague 225p) / Mid Cap .022uF Polyester Film(Sprague 225p) / Treble Cap 250pF Silver Mica/ Bright Cap 120pF Silver Mica

-Matched .1uF Output Coupling Capacitors

-Matched RN65 or RN70 220k Bias Splitter Resistors

-Hand Selected Metal Film 100k & 82K Phase Inverter Resistors

-Hand Select the Reverb input 500pf off of the .02 uF coupling capacitor of the V4a grid network. A Silver Mica capacitor should be used to keep the tolerance tight.

-Hand select the reverb mix 3.3 Meg Resistor and 10pF Capacitor paralleled with it. A Silver Mica capacitor should be used for the 10pF to keep the tolerance tight.

-The stock Reverb 100k linear potentiometer swapped for a 100k Log/Audio.

Re: Jerry Pre-amp mods

PostPosted:Mon Jun 06, 2011 1:51 pm
by hippieguy1954
I forgot to say, I wish I could get clarification about the component values. Time will tell! I will get to the bottom of this!

Re: Jerry Pre-amp mods

PostPosted:Mon Jun 06, 2011 5:51 pm
by schmidtz
Well I swapped all my coupling and power caps. There is nary a hum.

However, I must have screwed something up. Standby didn't work. It switched on fine, though (absolutely no hum!). Then, as I switched "on" off (leaving just standby on, no jewel light) it didn't work, then I strummed a couple times and it clicked on. Jewel light, the whole nine yards. No hums or anything. Then I switched standby off, and that bastard WAS STILL ON!

I had to unplug it. Sad panda! :cry:

Re: Jerry Pre-amp mods

PostPosted:Mon Jun 06, 2011 7:00 pm
by hippieguy1954
could be dust in the switch or the switch is just gettin old and loose. try flickin it on and off (with the power cord unplugged) might just be dust. I've had that happen a few times. You can feel if the switch is loose too if it moves on and off really easy with out much of a click.
Did you use the same values for the caps you replaced or did you use different values? What brand?