My new rig, 75 Twin Reverb!!! Questions...

My new rig, 75 Twin Reverb!!! Questions...

Postby Tony6Strings » Sun Feb 26, 2012 2:10 am

I made the trade!!! Swapped my 78 Pro Reverb for a 75 Twin... This thing is everything I want in an amp, I couldn't be happier! Here's the best part: came with an JBL d120, original cone. The other speaker is the stock Utah, it had us cracking up when I went to pick up the amp and it tilted dramatically towards the side of the JBL... This thing does the Jerry thing perfectly! Gonna get another d120 to throw in there. Also I gotta do something about the bright switch on the vibrato channel, it's finicky. Works one minute, then the next it doesn't. Wouldn't be a problem if it was stuck on bright, but that's not the case. Is there any way I could just bypass the switch and have it hard wired to run on bright? I know a new switch isn't spendy, but as I never use the off position on bright switch... Also, I'd like to get it recapped, just for peace of mind and best practice. I'm pretty handy with a soldering iron, but from what I understand, tube amps carry voltage long after having been unplugged, and it can kill you. Or so I've heard. So how's a guys supposed to work on one of these without getting barbecued? Had to change an on/off switch on my Pro, went well, but that's a pretty small job compared to switching out a set of caps. I don't wanna touch the wrong thing and go up in smoke... Last but not least, there's a crack.. Actually, I'll put that over on the cabinet forum. Any other tricks or tips for getting a Jerry sound out of this thing will be much appreciated.

:cool: :smile: :cool: :smile: :cool: :smile: :cool:
"Why do the best things always disappear, like Ophelia?"
User avatar
Tony6Strings
Brent
Brent
 
Posts: 93
Joined: Mon Dec 05, 2011 2:07 am
Location: Longview WA

Re: My new rig, 75 Twin Reverb!!! Questions...

Postby hippieguy1954 » Sun Feb 26, 2012 5:06 am

Tony6Strings wrote:I made the trade!!! Swapped my 78 Pro Reverb for a 75 Twin... This thing is everything I want in an amp, I couldn't be happier! Here's the best part: came with an JBL d120, original cone. The other speaker is the stock Utah, it had us cracking up when I went to pick up the amp and it tilted dramatically towards the side of the JBL... This thing does the Jerry thing perfectly! Gonna get another d120 to throw in there. Also I gotta do something about the bright switch on the vibrato channel, it's finicky. Works one minute, then the next it doesn't. Wouldn't be a problem if it was stuck on bright, but that's not the case. Is there any way I could just bypass the switch and have it hard wired to run on bright? I know a new switch isn't spendy, but as I never use the off position on bright switch... Also, I'd like to get it recapped, just for peace of mind and best practice. I'm pretty handy with a soldering iron, but from what I understand, tube amps carry voltage long after having been unplugged, and it can kill you. Or so I've heard. So how's a guys supposed to work on one of these without getting barbecued? Had to change an on/off switch on my Pro, went well, but that's a pretty small job compared to switching out a set of caps. I don't wanna touch the wrong thing and go up in smoke... Last but not least, there's a crack.. Actually, I'll put that over on the cabinet forum. Any other tricks or tips for getting a Jerry sound out of this thing will be much appreciated.

:cool: :smile: :cool: :smile: :cool: :smile: :cool:


Trebble - 10
Bass - 0
Mid - 4
Reverb - 4
Bright switch -off
If it has a master volume, turn it all the way up (this essentially takes it out of the circuit) and use channel volume for volume level.

Look here for information about caps and mods!
http://www.wald-electronics.com/preampmods.html
:smile: :smile: :smile:
Image
First show: 1973
Last show: 1994
User avatar
hippieguy1954
Senior Member
 
Posts: 1101
Joined: Thu Mar 24, 2011 1:29 pm
Location: Upstate, NY


Return to Jerry Tone

Who is online

Users browsing this forum: No registered users and 7 guests